Home    Products    Downloads    Purchase    Support    Company  
  Pocket Artist   Documentation   Download    Purchase    Gallery    Tutorials    Support  
Pocket Artist - Documentation



Contents


 

Documentation - Interface/Commands

Note: all screenshots are of the Palm-size PC version of Pocket Artist and most are dithered to 8-bit (256 color) GIF images for space reasons. Image quality in Pocket Artist is always retained at the 24-bit level, separate as to whatever color range your device's display can function at. In other words, image quality is a bit spared in this documentation so that it loads faster.

When you start Pocket Artist you will see the screen to the right as Pocket Artist initializes.


After initializing, you will see this screen. Pocket Artist was designed to scale down to Palm-size PCs. Its design guidelines intended to provide a rich feature set and not clutter up the interface as to make a negative impact on drawing. Therefore, in the current version there are no persistent floating toolbars. All tool selection is done via pop-ups and menu commands (however, the HPC has some shortcuts to these, and will be explained later).

The main whitespace is your image document. This is the canvas in which you draw, and upon loading, a blank image is created for you that is the exact height and width as big as to not create scrollbars onscreen. On the first toolbar is the menu and the tools bar. From left to right, the tools represent: Scroll Tools Left, Current Colors, Current Brush, Drawing Tools, Selection Tools, Text/Shape Tools, Edit Tools, Document Tools. Each pops up with multiple tools under each category.

The tool button with the darkened background is the current tool. Tapping on the current tool button will pop up the menu of tools, and tapping on a different tool button will select the last selected tool on the tool button tapped. By tapping and holding on another tool button, Pocket Artist will pop-up the tool seleciton menu for that tool button.

Most tools are persistent -- when you select them, the tool buttons will remain on that tool and that tool will be active whenever you tap and/or drag on the document window. Some are not, however, like the Cut/Copy/Paste tools, or the De-select tool. By selecting one of these non-persistent tools after the tool has completed its function, the last selected tool will become active again.

Pocket Artist's menus are as follows:

File Menu:

  • New: starts a new document. Will prompt if you want to save the current document.
  • Open: opens a document. Also will prompt.
  • Save: saves the document. If you have saved the image previously, or if you loaded the current image and have edited it, this command will save it without a prompt.
  • Save As: saves the document. This will prompt for a file name and saving type.
  • Close: closes the document. Will prompt if you want to save your changes.
  • Revert: loads back in the last saved iteration of this document.
  • Recent Files: this menu item holds a list of your recently opened, edited, or saved files.
  • Use as Desktop: this is a feature unique to Pocket Artist. By selecting this you can save your work straight to your Windows CE desktop, where it will appear there, optionally tiled.
  • Exit: exists Pocket Artist.


Edit Menu:

  • Undo: undoes the last command, whether it be a paint stroke or a document command (such as resizing the image).
  • Clear: fills the document (or the current selection) with the background color.
  • Cut: takes the current selection, moves it to the Pocket Artist clipboard (not system-wide as of version 1.1), and fills the current selected area of the document with the current background color.
  • Copy: takes the current selection and copies it to the Pocket Artist clipboard, retaining the selection and the document.
  • Paste: pastes in whatever is on the Pocket Artist clipboard into the document, retaining it as a floating selection so one can move it around, change the opacity or blending mode.
  • Zoom In/Out/100%: visually zooms in and out (or back to normal) of the document.
  • Deselect: deselects whatever is the selection.
  • Selection: this is a popup menu that contains the items on the left.
  • Defloat: if a selection is "floating", that is, if it contains color data (usually from moving, copying, or pasting a piece of an image), this command merges it down with the document using the current opacity and blending mode.
  • Feather: this blurs the current selection -- but it does not blur the color data of the selection but rather the selection itself.
  • Select All: selects the whole document.
  • Select Inverse: selects whatever is not selected, and deselects whatever was selected.
  • Toggle Outlines: the "marching ants" that appear as the boundary to your current selection will be hidden or shown by selecting this menu option.


Tools Menu:

  • Capture Screen: this prompts for a delay and then takes a snapshot of the screen and puts it on the clipboard. Paste it into the document to see what was captures.
  • Crop Image: this shrinks the current image, cropping it to the bounds of whatever selection you currently have.
  • Bright/Contrast: this adjusts the brightness and contrast of the image. A preview feature is enabled, so whatever changes you make in the window will be shown in the document window. The net effect will take place on the whole document, or if there is a selection, only on the selection.
  • Color Curves: this adjusts the color inputs and outputs of the red, green, or blue (or all three) values. It is adjusted in the form of a graph with the 0-255 values of the image in the X-axis, and the "output" 0-255 values of the image in the Y-axis. The curve starts out with a line of X = Y (no change). By adjusting this by simply drawing a new curve on the graph. For example, by drawing the curve shown to the left, the dark colors will be brighened a bit, the midrange colors darkened a bit, and so on. The curves also have a preview (you may need to move the window out of the way to see the effects) and will take effect on the whole document, or if there is a selection, on the selection.
  • Invert Colors: this changes black to white, blue to yellow, etc, inverting the color values. It takes effect on the whole document, or on the selection if there is one.
  • Image Size: this scales the image up or down to new dimensions. You may specify whether to "constrain proportions", that is, to keep the image aspect ratio the same after the scaling. Also available as an option is which interpolation mode to choose. Nearest neighbor is the fastest, but can be blocky when sizing images. Bilinear interpolation is better, but can lead to an unusual appearance if scaled too much. Bicubic is the best and slowest option, and results in better output.
  • Canvas Size: this function does not scale the image but instead cuts or adds to the canvas, giving it a new set of dimensions. The Anchor area specifies how you would like the pre-affected image to be placed in the new image -- in this case it would be aligned to middle left, with the right side of the image being cut off just a bit.
  • Filters: this popup contains the filters which you can apply to the document (or to the selection if there is one). Blur, Desaturate, Emboss, Find Edges, Motion Blur, Sharpen, or Sharpen More.


>> Opening/Saving Files

 

© Copyright 2012 Conduits Technologies, Inc. All Rights Reserved.
Big thoughts in small spots.

Conduits develops Pocket PC, Handheld PC and Windows Mobile software
for devices such as the HP iPAQ, Dell Axim, Palm Treo 700w and Pocket PC Phone Edition.
Questions or comments about our website? Let us know.