Pocket Album Portable Documentation
Product Overview

The main interface of Pocket Album consists of the active image in the main window, the album
status displayed on the title bar, and the menu bar. By tapping on the image, Pocket Album will
toggle between this mode of display and full-screen mode.
Pocket Album has two methods of organizing and queuing images for display: Album mode and
SmartAlbum mode. Album mode represents setting up a finite set of images, sorting them,
and browsing them. The "next image to display" is simply the next image in the set. SmartAlbum
is a bit different. When active, SmartAlbum keeps watch over a set of folders on the device
and tries to find any new images on the device. If it succeeds, it adds the picture to the queue.
If it can't find a new image, it finds an old picture it hasn't shown in a while, and queues that. Tap
'Album' to switch modes.
To start a slideshow, simply tap the 'Play' button. The delay between pictures is set via the
Tools->Options menu. To manually advance to the next picture, or jump back to the
previous image, use the 'Back' and 'Forward' buttons.

Common Uses
To use as a simple photo album: first tap Album->Album Mode. Create a new album, and
Pocket Album will prompt you for a directory of images to add. After adding a group of images,
tap Album->Properties to change the ordering of the images, and tap 'Play' to start the slide
show.
To use as an intelligent picture frame: tap Album->SmartAlbum, and 'Play.' Configure the
folders to scan by tapping Tools->Options->SmartAlbum.
To set up a presentation: set up an Album, then sort the slides on Album->Properties screen.
To copy a set of PowerPoint slides onto the device: open up your presentation on the desktop
PC and click File->Save As, selecting GIF or JPEG as the output format, then copy those slides
to the device.
---------------------------------------------------------------------------------------

User Interface
Tap image: toggles full-screen mode. When in 'VGA Display' mode, it advances to the next slide.
While in 'Zoom and Pan' mode, it pans around on the zoomed image.
Album menu:
SmartAlbum mode: activates SmartAlbum mode.
Album mode: activates Album mode, opening the last active album
automatically.
New/Open Album: creates a new album or opens an existing one.
Add Picture/Folder: adds images to an album.
Go To: lists all images for the current mode, with optional thumbnail graphics.
Properties: adjusts album properties.
Tools menu:

Play Sounds: choose to play sounds associated with images.
VGA Display: choose to output to an attached VGA card.
Zoom and Pan: toggles zooming mode.
Rescale Image: scales a large image down to the device's dimensions.
Keep Image: saves a temporary image created by PhotoSync by renaming it.
JPEG Transform: performs lossless JPEG transformations, such as rotation or flipping, on an
image, saving the changes.
Edit Picture: opens the current image.
Options: configures Pocket Album.
About: information page.
Play: toggles the slide show.
Back/Forward: previous or next image.
Notes: toggles the Notes associated with an image.
Recorder: toggles the Recording associated with an image.

Options/Preferences
There are two places to adjust the different properties of Pocket Album.
Tools->Options relates to preferences of SmartAlbum mode, and Album mode.
The Options display has several screens: Photos, SmartAlbum, Rotations, Scaling, Fading, and
Advanced. Each screen configures an aspect of Pocket Album.

Delay between pictures: time to wait between pictures when SmartAlbum is in slideshow mode.
Optimize for 12-bit display: dithers images to display on devices with 12-bit screens.
Show picture filename: displays name of the current image.
Show/hide notes: will automatically pop up the notes window.
Wait for sounds to complete: program will wait for the sound to complete before advancing.
Start in full-screen mode: starts up program in full-screen mode.
Use alternate extension for notes: uses an alternate extension for notes and sounds (PWI2
and WAV2) instead of the default file extensions for notes and sounds (PWI and WAV). This will
disable ActiveSync from syncing any of these items (which might clutter up the Notes view in
Outlook on the desktop).

Directories containing photos: where SmartAlbum will look for pictures.

Rotation / Scaling screens are explained in the Image Display section.

Fading enabled: chooses transitions to be used when switching between pictures.
Fade types: different fading modes.
Fade only when full-screen: determines fading presence.
Fade at 2x speed: speeds up the transition effects.

Associate Pocket Album with file types: when tapping a file of the desired file type, Pocket
Album will be launched and the image displayed.
Image quality: adjusts the tradeoff between loading time and image quality.
VGA settings: enabled when the drivers for a compatible VGA card are installed on the device.

Resolution: adjusts the display and output resolution of the image.
Palette type: on palletized devices, better image quality may be achieved by selecting a different
256-color palette for the image
Dither image: dithers the image to the output palette, further increasing the image quality.
Disable fading: disables fading effects to the VGA output.

Image Display

Pocket Album contains advanced methods of rotating and scaling images, allowing for full
customization of pictures displays.
Always rotate: always take the source image and rotate it 90° counter-clockwise.
Never rotate: never rotate the source image.
Smart rotate: selectively rotate the source image based on its dimensions. For a Pocket PC
running in portrait mode, the portrait-oriented images would not be rotated, but landscapeoriented images would be rotated to fit the screen.
Pocket Album automatically scales images down to the device dimensions as it loads them. This
behavior can be fine-tuned by adjusting the settings on the Scaling tab named 'Scale up and
crop'. Generally, Pocket Album will shrink an image down to the device screen, adding in the
"black bars" so it can fit the whole image on the device screen.

When the image is rotated, the black bars come into effect, although the size of the image takes
up on-screen is much larger. With "scale up and crop" turned on, it will eliminate the black bar
problem, and will fill the whole display. At the same time, however, this also means that the sides
of the image have been cropped off in order to fill the display:

The rotation and scaling settings are granular - different settings are applied under different
circumstances. The diagram shows the paradigm of the default settings for rotation and settings:
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The settings under Tools->Options serve as the defaults for specific albums in Album mode. For
example, for a normal photo album, the default settings will most likely be appropriate. For an

album containing a set of presentation slides, the "scale up and crop" settings will not be
appropriate. Disable it under Album->Properties.

--------------------------------------------------------------------------------------------

SmartAlbum Mode
As described before, SmartAlbum Mode simply loops over all the directories as specified
under Tools->Options->SmartAlbum.
It will detect when images are deleted (thus removing them from the queue) and will detect when
images are added (thus adding them to the queue) to those directories.
--------------------------------------------------------------------------------------------

Album Mode
Album Mode queues a subset of images on the device is for viewing. To create a new
album, tap Album->New Album. To add pictures, tap Album->Add Picture or Album->Add
Folder.
By checking the "Symbolic Reference" under the Add Folder screen, Pocket Album will refresh
the list of images in that directory (much like SmartAlbum) whenever the Album is loaded. This is
useful when targeting an album to a CompactFlash card from a digital camera. By creating an
album containing a symbolic link to a folder on a memory card, Pocket Album can detect when
new pictures have been taken with the digital camera, and have them ready for viewing.

Album->Preferences:

Image List: this is used to sort the images.
Other buttons are self-explanatory.

Picture delay: governs the delay for slideshow mode for this album.
Loop album: loop the album when played in slideshow mode.
Only show borders when full-screen: omit any themed borders unless in full-screen mode.
Scale borders to fit window: scale a border to the size of the image window area, in case the
border is not the same size as the image window.
Align pictures at top: will dock an image at the top of the screen if it is not being scaled up (see

the following section on scaling), which allows the Notes window to not cover up the image.

Picture mask: Pocket Album supports the overlay of themed borders to a set of pictures in an
album. By associating a border to an album, it will load the next image in the album, and then
place the border on top of it, creating a themed effect. Several borders are included with Pocket
Album, such as holiday, wedding, and party themes.

Rotations and scaling settings: these either defer to how Pocket Album is set up on the Tools>Options screen, or overrides such values for this album.

Image Management
At this time, Pocket Album does not support any management of the image files themselves.
To delete or rename an image on your device, use the File Explorer application.

PhotoSync
PhotoSync feeds images to the device at a given interval, which refreshes the device with everchanging content. Pointing PhotoSync at your desktop's "My Pictures" folder (with, for example,
1000 images that have been taken with a digital camera) will load in a few of those images at a
time to the device.
PhotoSync will download an image from that folder to the device every few minutes (or however
you have it set in PhotoSync settings). They are downloaded to the device's \My Documents\
directory and art named "PhotoSync_1234.jpg" -- where 1234 is an incrementing number
(increments with each download). If Pocket Album is running and is in SmartAlbum mode, it will
loop over all the images on your device, and will detect the new images being loaded to your
device, creating a virtual picture frame on your device. There should be options if you open up
ActiveSync and click Options, then PhotoSync, then click Options again.
Also, note that it scales the photos down before transferring them, so the resident size of the
synced images is under 100K usually. This is only featured in the PhotoSync system and not in
the general ActiveSync file copy system. If you are viewing a picture in Pocket Album that is a
large JPEG, the command Tools->Resize Image will shrink it down to the device dimensions.

Tapping Tools->Keep Image will rename the PhotoSync_0001.jpg filename to Image_1.jpg,
which will not be deleted by PhotoSync. This is useful when PhotoSync downloads an image you
would like to keep on the device.

Advanced Usage
Zoom and Pan: Pocket Album supports a zoomed mode of images.

Tapping Tools->Zoom and Pan will toggle between zoomed mode and normal mode.
Drag around the screen with the stylus in order to pan around on the image.
VGA Display: Pocket Album will output to a connected VGA card if Tools->VGA Display is
enabled. The User Interface of Pocket Album changes when VGA output is active:

JPEG Transforms: Pocket Album can perform lossless JPEG transforms, just as permanent
rotations or flipping of JPEG images.

Unfortunately, the lossless JPEG transformations are memory-dependent. If the device does not
have enough memory to load the entire source JPEG information in memory, it will fail.

Notes: Pocket Album supports notes:

Tapping the Notes button will pop-up a Notes window which will save/load notes with the same
name as the image you are viewing (e.g. Demo1.jpg's notes will be named Demo1.pwi). To
delete an attached note, select all of the contents of the note, and delete it.
Recordings: Pocket Album supports "talking pictures":

Tapping the speaker button will pop up a recording window which will save/load notes with the
same name as the image you are viewing (e.g. Demo1.jpg's notes will be named Demo1.wav).
To delete a note, tap the 'X' button on the recording window.

Tutorials/How-to’s
How do I view all images on my device?
Simply point SmartAlbum at the folders that have images, and then press play. To see thumbnails
of all your images, tap Album->Go To, and then click 'Show Thumbnails.'

How do I set up a slideshow?
Create an album via Album->New Album, add pictures to the folder, and then simply press Play.
Tapping the image will toggle fullscreen mode.
How can I create a picture frame effect?
While in the cradle, launch Pocket Album, go into SmartAlbum mode, and then tap the screen to
switch into fullscreen mode. If PhotoSync is enabled, SmartAlbum will "catch" new images that
are downloaded, and the device will behave like an intelligent picture frame.
How do I show a presentation?
Open your presentation on the desktop, and click File->Save As, saving to the GIF, JPEG, or
PNG file formats. You will encounter a set of images named Slide1, Slide2, etc. Copy these files
to the device, and then in Pocket Album, create an Album and add these pictures to the album.
Then, sort them via Album->Properties. Tapping Tools->VGA Display will output it to the VGA
card (note that for Voyager VGA card users: running the Voyager Shadow program is not
needed. Pocket Album talks directly to the VGA card), and at that point, tapping the screen will
advance to the next slide.

How do I load pictures from a memory card?
Simply create an Album and add the CompactFlash folder into the album, or add the same
directory into the SmartAlbum options (in Tools->Options) to get them to show in SmartAlbum
mode.
How do I take pictures with me?
To copy images to the device, first connect the device to the desktop. Then, double-click the
ActiveSync icon in your System Tray and then click the "Explore" button in the ActiveSync
window. This will open the "My Documents" folder on your device. Now, simply drag any images
from your desktop into this window. Doing so will copy the image onto your device. The Tools>Resize Image command inside of Pocket Album is useful in saving space on your device, as it
will shrink large images down to the device's dimensions.

What does ____ mean?
Dithering: this simply means to compensate for the quality degradation that occurs when
converting from a large color space (such as 24-bit RGB color) to a smaller color space (such as
a 256-color palette). Dithering involves the "spreading out" of the color quantification artifacts
throughout the whole image. In simpler terms, it turns the "banding effect" into a "noise effect".
Here are two images that have been converted to the Windows palette, one without dithering and
one with dithering:

Portrait: refers to when the vertical dimension is a greater value than the horizontal dimension.
Landscape: refers to when the horizontal dimension is a greater value than the vertical
dimension.
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